Lounge IT Engineer

關於部落格
以傭懶為生的工程師筆記誌...
  • 74320

    累積人氣

  • 5

    今日人氣

    0

    訂閱人氣

[VMware] ESXi 5.5 upgrade to 6.0U2 DependencyError issue

 今日作ESXi 5.5U2 upgrade to ESXi 6.0U2 使用ESXi CLI update happen some issue , messages as below

[DependencyError]
 VIB VMware_bootbank_esx-base_6.0.0-2.34.3620759 requires vsan >= 6.0.0-2.34, but the requirement cannot be satisfied within the ImageProfile.
 VIB VMware_bootbank_esx-base_6.0.0-2.34.3620759 requires vsan << 6.0.0-2.35, but the requirement cannot be satisfied within the ImageProfile.
 Please refer to the log file for more details.


solution for ESXi CLI

step1.
# esxcli software sources profile list -d /path/Vmware-ESXi-6.0.0-3620759-Custom-Cisco-6.0.2.1-Bundle.zip
display profile information 記得下它
Name                                                                                        Vendor    Acceptance Level
------------------------------------------------------------------------    ----------   ------------------------
Vmware-ESXi-6.0.0-3620759-Custom-Cisco-6.0.2.1     Cisco      PartnerSupported
 
step2.
# esxcli software profile update -p Vmware-ESXi-6.0.0-3620759-Custom-Cisco-6.0.2.1 -d /path/Vmware-ESXi-6.0.0-3620759-Custom-Cisco-6.0.2.1-Bundle.zip

step3.
# esxcli software vib install -n esx-base -n vsan -n vsanhealth -d /path/Vmware-ESXi-6.0.0-3620759-Custom-Cisco-6.0.2.1-Bundle.zip

step4.
Reboot apply new esxi version

後記:
若是用vSphere Update Manager (VUM) 或是 放置ISO方式(pre-boot)是不會有以上產牛相依性這類狀況唷!!



Reference :

VMware KB 2144595 ( Dealing with vSAN VIB issues in ESXi 6.0 Update 2 and later releases )
相簿設定
標籤設定
相簿狀態